指標大全 移動平均線 MACD KDJ 成交量 BOLL RSI OBV CCI DMI 乖離率 SAR 威廉指標 寶塔線 | 股票公式 通達信指標 同花順 飛狐 東方財富 大智慧 股票書籍下載
                                                                        當前位置股竄網 > 指標公式 > 通達信公式 >
                                                                        熱門搜索: 趨勢  戰法  均線  短線  期貨  量價

                                                                        通達信安全背離指標公式源碼

                                                                        時間:2019-08-22 21:26 來源:股竄網 作者:gucuan 閱讀:
                                                                        以下是股竄網(www.sonic-scenarios.com)為你提供的:通達信安全背離指標公式源碼
                                                                        通達信安全背離指標公式
                                                                        N1:=5;N2:=10;
                                                                        LC:=REF(CLOSE,1);
                                                                        A0:=(2*C+H+L)/4;
                                                                        均線:=MA(A0,3)>REF(MA(A0,3),1);
                                                                        安全線:2,COLORRED,POINTDOT,LINETHICK4;
                                                                        A1:=(CLOSE-LLV(LOW,7))/(HHV(HIGH,7)-LLV(LOW,7))*10;
                                                                        K:MA(3*SMA(A1,6,1)-2*SMA(SMA(A1,5,1),5,1),3),LINETHICK1,COLORF00FF0;
                                                                        D:MA(K,3),COLORFF0000,LINETHICK1;
                                                                        J:3*K-2*D,LINETHICK1,COLORF00FF0;
                                                                        DRAWBAND(K,RGB(155,50,50),D,RGB(0,100,50));
                                                                        VAR1:=C-REF(C,1);
                                                                        VAR2:=100*EMA(EMA(VAR1,6),6)/EMA(EMA(ABS(VAR1),6),6);
                                                                        MA5:=EMA(C,5);
                                                                        MA13:=EMA(C,13);
                                                                        UP:=DRAWLINE(L=LLV(L,BARSLAST(CROSS(MA13,MA5))+1),LLV(L,BARSLAST(CROSS
                                                                        (MA13,MA5))+1),H=HHV(H,BARSLAST(CROSS(MA5,MA13))+1),HHV(H,BARSLAST(CROSS
                                                                        (MA5,MA13))+1),0),COLOR0000FF;
                                                                        DOWN:=DRAWLINE(H=HHV(H,BARSLAST(CROSS(MA5,MA13))+1),HHV(H,BARSLAST(CROSS
                                                                        (MA5,MA13))+1),L=LLV(L,BARSLAST(CROSS(MA13,MA5))+1),LLV(L,BARSLAST(CROSS
                                                                        (MA13,MA5))+1),0),COLOR00FF00;
                                                                        BT:=(LLV(VAR2,2)=LLV(VAR2,7) AND COUNT(VAR2<0,2) AND CROSS(VAR2,MA(VAR2,2))) AND
                                                                        REF(DOWN,1)<REF(DOWN,2) AND UP>REF(DOWN,1);
                                                                        底線:0,COLORFF00FF;
                                                                        頂線:10,COLORFF0000;
                                                                        STICKLINE(UP,0,0.2,3,0),COLOR0000FF;
                                                                        STICKLINE(DOWN,0,0.2,3,0),COLOR00FF00;
                                                                        STICKLINE(BT,0,3,2,0),COLOR000088;
                                                                        STICKLINE(BT,0,3,1,0),COLOR0000CC;
                                                                        STICKLINE(BT,0,3,0.22,0),COLOR0000FF;
                                                                        DRAWTEXT(BT,3,'短牛'),COLOR0000FF;
                                                                        TJ1:=REF(DOWN,1)<REF(DOWN,2) AND UP>REF(DOWN,1) AND C<HHV(H,21)*0.82;
                                                                        STICKLINE(TJ1,0,2,3,0),COLOR880088;
                                                                        STICKLINE(TJ1,0,2,1.5,0),COLORAA00AA;
                                                                        STICKLINE(TJ1,0,2,0.8,0),COLORCC00CC;
                                                                        STICKLINE(TJ1,0,2,0.2,0),COLORFF00FF;
                                                                        DRAWTEXT(TJ1,2,'中牛'),COLORFF00FF;
                                                                        HR:=HHV(HIGH,55);
                                                                        HRY:=LLV(LOW,55);
                                                                        HRY11:=HR*HRY;
                                                                        HRY33:=SQRT(HRY11);
                                                                        TJ2:=REF(DOWN,1)<REF(DOWN,2) AND UP>REF(DOWN,1) AND C<HRY33;
                                                                        STICKLINE(TJ2,0,1,5,0),COLOR008888;
                                                                        STICKLINE(TJ2,0,1,2,0),COLOR00AAAA;
                                                                        STICKLINE(TJ2,0,1,1,0),COLOR00CCCC;
                                                                        STICKLINE(TJ2,0,1,0.2,0),COLOR00FFFF;
                                                                        DRAWTEXT(TJ2,1,'大牛'),COLOR00FFFF;
                                                                        ST:=REF(UP,1)>REF(UP,2) AND DOWN<REF(UP,1);
                                                                        STICKLINE(ST,10,9,5,0),COLOR008800;
                                                                        STICKLINE(ST,10,9,2,0),COLOR00AA00;
                                                                        STICKLINE(ST,10,9,1,0),COLOR00CC00;
                                                                        STICKLINE(ST,10,9,0.2,0),COLOR00FF00;
                                                                        DRAWTEXT(ST,9,'賣'),COLOR00FF00;
                                                                        DIFF:EMA(DCLOSE,12)-EMA(DCLOSE,26);
                                                                        DEA:EMA(DIFF,9),COLORFFFF00;
                                                                        A11:=BARSLAST(REF(CROSS(DIFF,DEA),1));
                                                                        底背離:=REF(CLOSE,A11+1)>CLOSE AND DIFF>REF(DIFF,A11+1) AND CROSS(DIFF,DEA);
                                                                        DRAWTEXT(底背離,-0.6,'底背離'),COLORWHITE;
                                                                        A22:=BARSLAST(REF(CROSS(DEA,DIFF),1));
                                                                        頂背離:=REF(CLOSE,A22+1)<CLOSE AND REF(DIFF,A22+1)>DIFF AND CROSS(DEA,DIFF);
                                                                        DRAWTEXT(頂背離,11,'頂背離'),COLORWHITE;
                                                                        推薦圖文

                                                                        Copyright @ GuCuan.com 股竄網 版權所有 免責聲明:本站所發表的內容僅用于學術交流,內容所帶來的一切后果均與本站無關。 若您發現本站存在您非授權的原創作品,請第一時間聯系本站刪除!

                                                                        溫馨提示:本站不從事任何收費業務,如遇到以此名義收費,請提高警惕,謹防上當受騙! 本站所有信息免費,所有廣告和涉及鏈接,與股竄網均無任何關系,請股友自行判斷真假。

                                                                        豫ICP備14026518號-1 下載幫助-關于本站-版權聲明-聯系我們- 隱私條款-

                                                                        精品国产乱码久久久久久蜜桃,一二三四电影在线观看,亚洲熟妇AV欧差AA片爽