指標大全 移動平均線 MACD KDJ 成交量 BOLL RSI OBV CCI DMI 乖離率 SAR 威廉指標 寶塔線 | 股票公式 通達信指標 同花順 飛狐 東方財富 大智慧 股票書籍下載
                                                                        當前位置股竄網 > 指標公式 > 通達信公式 >
                                                                        熱門搜索: 趨勢  戰法  均線  短線  期貨  量價

                                                                        一陽定勢+強勢突破 自動畫線 可修改源碼做預警公式

                                                                        時間:2021-05-31 20:16 來源:股竄網 作者:gucuan 閱讀:
                                                                        一陽定勢+強勢突破 自動畫線 可修改源碼做預警公式
                                                                        筆周期:=3;
                                                                        畫趨勢:=0;
                                                                        A1:=REF(HIGH,3)=HHV(HIGH,筆周期*3+1);
                                                                        B1:=FILTER(A1,3);
                                                                        C1:=BACKSET(B1,3+1);
                                                                        D1:=FILTER(C1,3);{高點}
                                                                        A2:=REF(LOW,3)=LLV(LOW,筆周期*3+1);
                                                                        B2:=FILTER(A2,3);
                                                                        C2:=BACKSET(B2,3+1);
                                                                        D2:=FILTER(C2,3);{低點}
                                                                        E1:=(REF(LLV(LOW,2*3),1)+REF(HHV(HIGH,2*3),1))/2;
                                                                        E2:=(HIGH+LOW)/2;{高低點出現在同一K線上時可作取舍}
                                                                        H1:=(D1 AND NOT(D2 AND E1>=E2)) OR BARSTATUS=2 OR BARSCOUNT(CLOSE)=1;
                                                                        H2:=D1 AND NOT(D2 AND E1>=E2);
                                                                        L1:=D2 AND NOT(D1 AND E1=E2);
                                                                        X1:=REF(BARSLAST(H1),1)+1;
                                                                        F1:=BACKSET(H1 AND COUNT(L1,X1)>0,LLVBARS(IF(L1,LOW,10000),X1));
                                                                        G1:=F1>REF(F1,1);
                                                                        I1:=BACKSET(G1,2);
                                                                        LD:=I1>REF(I1,1);{過濾后低點}
                                                                        L2:=LD OR BARSTATUS=2 OR BARSCOUNT(CLOSE)=1;
                                                                        X2:=REF(BARSLAST(L2),1)+1;
                                                                        F2:=BACKSET(L2 AND COUNT(H2,X2)>0,HHVBARS(IF(H2,HIGH,0),X2));
                                                                        G2:=F2>REF(F2,1);
                                                                        I2:=BACKSET(G2,2);
                                                                        HD:=I2>REF(I2,1);{過濾后高點}
                                                                        DRAWLINE(LD,L,HD,H,0),COLORYELLOW,LINETHICK1;
                                                                        DRAWLINE(HD,H,LD,L,0),COLORYELLOW,LINETHICK1;
                                                                        J1:=BACKSET(BARSTATUS=2,MIN(BARSLAST(HD),BARSLAST(LD))+1);
                                                                        J2:=J1>REF(J1,1);
                                                                        A3:=H;
                                                                        B3:=REF(H,REF(BARSLAST(HD),1)+1)>REF(H,REF(BARSLAST(HD),1)+2+REF(BARSLAST(HD),REF(BARSLAST(HD),1)+2));DRAWTEXT_FIX(1,0.980,20,1,'★股竄網GUCUAN.COM'),COLOR666666;
                                                                        D3:=A3 AND B3 AND HD;
                                                                        E3:=BACKSET(D3,REF(BARSLAST(HD),1)+2);
                                                                        HH:=E3>REF(E3,1);{找出全部長期高點}
                                                                        A4:=L>REF(L,REF(BARSLAST(LD),1)+1);
                                                                        B4:=REF(L,REF(BARSLAST(LD),1)+1);
                                                                        D4:=A4 AND B4 AND LD;
                                                                        E4:=BACKSET(D4,REF(BARSLAST(LD),1)+2);
                                                                        LL:=E4>REF(E4,1);{找出全部長期低點}
                                                                        H3:=HH OR BARSTATUS=2 OR BARSCOUNT(C)=1; {后面進行過濾,方法同前。只是不用考慮高低點出現在同一K線}
                                                                        X3:=REF(BARSLAST(H3),1)+1;
                                                                        F3:=BACKSET(H3 AND COUNT(LL,X3)>0,LLVBARS(IF(LL,L,POW(10,20)),X3));
                                                                        G3:=F3>REF(F3,1); I3:=BACKSET(G3,2);
                                                                        LZ:=I3>REF(I3,1); {長期低點,也可供引用}
                                                                        L4:=LZ OR BARSTATUS=2 OR BARSCOUNT(C)=1;
                                                                        X4:=REF(BARSLAST(L4),1)+1;
                                                                        F4:=BACKSET(L4 AND COUNT(HH,X4)>0,HHVBARS(IF(HH,H,-POW(10,20)),X4));
                                                                        G4:=F4>REF(F4,1); I4:=BACKSET(G4,2); HZ:=I4>REF(I4,1);{長期高點,也可供引用}
                                                                        K1:=BACKSET(BARSTATUS=2,MIN(BARSLAST(HZ),BARSLAST(LZ))+1); K2:=K1>REF(K1,1);
                                                                        UU:=BACKSET(BARSTATUS=2,BARSLAST(LD)+1);
                                                                        VV:=UU>REF(UU,1);
                                                                        WW:=BACKSET(VV,REF(BARSLAST(LD),1)+2);
                                                                        XX:=WW>REF(WW,1);
                                                                        WWQ:=BACKSET(XX,REF(BARSLAST(LD),1)+2);
                                                                        XXQ:=WWQ>REF(WWQ,1);
                                                                        下軌:=DRAWLINE(XX,L,VV,L,1),COLORMAGENTA,LINETHICK2;{畫趨勢線}
                                                                        UU2:=BACKSET(BARSTATUS=2,BARSLAST(HD)+1);
                                                                        VV2:=UU2>REF(UU2,1);
                                                                        WW2:=BACKSET(VV2,REF(BARSLAST(HD),1)+2);
                                                                        XX2:=WW2>REF(WW2,1);
                                                                        WW3Q:=BACKSET(XX2,REF(BARSLAST(HD),1)+2);
                                                                        XX3Q:=WW3Q>REF(WW3Q,1);
                                                                        WW4Q:=BACKSET(XX3Q,REF(BARSLAST(HD),1)+2);
                                                                        XX4Q:=WW4Q>REF(WW4Q,1);
                                                                        上軌:=DRAWLINE(XX2,H,VV2,H,1),COLORMAGENTA,LINETHICK2;{畫趨勢線};
                                                                        上軌1:=DRAWLINE(XX2,H,VV2,H,1);
                                                                        Q0:=BARSLAST(XX2>0);
                                                                        Q1:=BARSLAST(XX>0);
                                                                        Q2:=BARSLAST(WW2>0);
                                                                        Q3:=BARSLAST(VV>0);
                                                                        Q4:=BARSLAST(XXQ>0);
                                                                        Q5:=BARSLAST(XX3Q>0);
                                                                        Q6:=BARSLAST(XX4Q>0);
                                                                        近期低:REF(L,BARSLAST(VV)),DOTLINE,COLOR99FF66;
                                                                        近期高:REF(H,BARSLAST(VV2)),DOTLINE,COLOR99FF66;
                                                                        上次低:REF(L,BARSLAST(XX)),DOTLINE,COLORFF66FF;
                                                                        上次高:REF(H,BARSLAST(XX2)),DOTLINE,COLORFF66FF;
                                                                        ABC:=IF(Q5>Q4,REF(L,BARSLAST(XXQ)),0),DOTLINE,COLORCYAN;
                                                                        ①②③:=IF(Q5<Q4,REF(H,BARSLAST(XX3Q)),0),DOTLINE,COLORCYAN;
                                                                        筆:DRAWLINE(J2,IF(HD,H,L),BARSTATUS=2,IF(BARSLAST(HD)>BARSLAST(LD),H,L),0),DOTLINE,COLORYELLOW,LINETHICK1;
                                                                        DRAWTEXT( VV=1 AND Q0>Q1,L,'C')COLORMAGENTA;
                                                                        DRAWTEXT(VV2=1 AND Q0>Q1,H,'B')COLORMAGENTA;
                                                                        DRAWTEXT( XX=1 AND Q0>Q1,L,'A')COLORMAGENTA;
                                                                        DRAWTEXT(XX2=1 AND Q5>Q4 ,H,'◆2')COLORMAGENTA;
                                                                        DRAWTEXT(XXQ=1 AND Q5>Q4 ,L,'◆1')COLORMAGENTA;
                                                                        DRAWTEXT( VV=1 AND Q0<Q1,L,'B-')COLORMAGENTA;
                                                                        DRAWTEXT(VV2=1 AND Q0<Q1,H,'C-')COLORMAGENTA;
                                                                        DRAWTEXT(XX2=1 AND Q0<Q1,H,'A-')COLORMAGENTA;
                                                                        DRAWTEXT(XX=1 AND Q5<Q4,L,'◆2')COLORMAGENTA;
                                                                        DRAWTEXT(XX3Q=1 AND Q5<Q4,H,'◆1')COLORMAGENTA;
                                                                        V00:=HIGH<REF(HIGH,1) AND LOW<REF(LOW,1);
                                                                        V01:=HIGH<REF(HIGH,1) AND LOW>REF(LOW,1);
                                                                        V02:=HIGH>REF(HIGH,1) AND LOW<REF(LOW,1);
                                                                        V03:=HIGH>REF(HIGH,1) AND LOW>REF(LOW,1);
                                                                        V04:=REF(HIGH,2)<HIGH AND REF(LOW,2)<LOW AND REF(HIGH,2)>REF(HIGH,1) AND REF(LOW,2) < REF(LOW,1);
                                                                        V1:=COUNT(V00,3)>=1 AND LLVBARS(LOW,3)=1 AND V03;
                                                                        V2:=COUNT(V00,4)>=1 AND LLVBARS(LOW,4)=2 AND V04;
                                                                        V3:=COUNT(V00,4)>=1 AND COUNT(V01 OR V02,4)=1 AND LLVBARS(LOW,4)=1 AND V03;
                                                                        V4:=COUNT(V00,5)>=1 AND COUNT(V01 OR V02,5)=2 AND LLVBARS(LOW,5)=2 AND V04;
                                                                        XG1:=V1 OR V2 OR V3 OR V4;
                                                                        XG2:=C>REF(HIGH,1);
                                                                        XG:=XG1 AND XG2;
                                                                        {收斂突破:=上次低<近期低 AND 上次高>近期高 AND CROSS(C,上軌) AND C>O;
                                                                        DRAWTEXT(收斂突破=1,L,'收斂突破'),COLORYELLOW;}
                                                                        突破:=CROSS(C,近期高) AND C>O;
                                                                        STICKLINE(突破,OPEN,CLOSE,2.8,0),COLORMAGENTA;
                                                                        強勢突破:=上次低<近期低 AND 上次高<近期高 AND CROSS(C,近期高) AND C>O;
                                                                        STICKLINE(強勢突破,OPEN,CLOSE,2.8,0),COLORMAGENTA;
                                                                        DRAWTEXT(強勢突破=1,H,'強勢突破'),COLORYELLOW;
                                                                        {反彈突破:=CROSS(C,上次低) AND C>O;
                                                                        STICKLINE(反彈突破,OPEN,CLOSE,2.8,1),COLORMAGENTA;
                                                                        STICKLINE(反彈突破,OPEN,CLOSE,1,1),COLORWHITE;
                                                                        DRAWTEXT(反彈突破=1,L,'反彈突破'),COLORYELLOW;}
                                                                        DRAWTEXT(突破=1,L,' 突破'),COLORYELLOW;
                                                                        一陽定勢:=CROSS(C,近期高) AND CROSS(C,上次高) AND C>O;
                                                                        STICKLINE(一陽定勢,OPEN,CLOSE,2.8,0),COLORMAGENTA;
                                                                        DRAWTEXT(一陽定勢=1,(OPEN+CLOSE)/2,' 一陽定勢'),COLORRED;

                                                                        STICKLINE(一陽定勢,OPEN,CLOSE,1,0),COLORYELLOW;
                                                                        STICKLINE(強勢突破,OPEN,CLOSE,1,0),COLORYELLOW;

                                                                        推薦圖文

                                                                        Copyright @ GuCuan.com 股竄網 版權所有 免責聲明:本站所發表的內容僅用于學術交流,內容所帶來的一切后果均與本站無關。 若您發現本站存在您非授權的原創作品,請第一時間聯系本站刪除!

                                                                        溫馨提示:本站不從事任何收費業務,如遇到以此名義收費,請提高警惕,謹防上當受騙! 本站所有信息免費,所有廣告和涉及鏈接,與股竄網均無任何關系,請股友自行判斷真假。

                                                                        豫ICP備14026518號-1 下載幫助-關于本站-版權聲明-聯系我們- 隱私條款-

                                                                        精品国产乱码久久久久久蜜桃,一二三四电影在线观看,亚洲熟妇AV欧差AA片爽